Duo Desktop Error on Browser

Summary

Browser issues with Duo: Google Chrome Version 142 and Microsoft Edge 143 Changes Affecting Duo Desktop

Symptoms

Google Chrome version 142 and Microsoft Edge 143 include a change that causes users to see a permission prompt whenever a website attempts to send an HTTP(S) request to a device on the local network or to the loopback connection on the local machine.

This local loopback connection is the mechanism that the Duo Prompt uses to send requests to Duo Desktop

 

To resolve this, the Chrome or Edge browser settings must be updated to enable the local connection. This setting is called Local network access, and can be managed by users themselves when the browser is unmanaged (Personal Computers)

 

DUO Error

Environment

Google Chrome Version 142, Microsoft Edge 143 and Duo

Solution

Edge version 143 or later:

If you’re an individual user running Edge version 143 or later:

  1. Navigate directly to edge://flags/#local-network-access-check and set it to Enabled. Click the Restart button to relaunch Edge with this updated setting.

  2. Navigate to edge://settings/privacy/sitePermissions/allPermissions. Scroll down to and click the Local Network Access setting.

  3. Click the Add site button to the right of Allowed to connect to any device on your local network.

  4. In the text box that appears, enter [*.]duosecurity.com

 

Chrome version 142 or later:

If you’re an individual user running Chrome version 142 or later, you can navigate directly to chrome://settings/content/localNetworkAccess and then at the bottom of the page add [*.]duosecurity.com to the list titled Allowed to connect to any device on your local network.

To navigate to this setting manually:

  1. In Chrome, select the three vertically stacked dots in the upper right to bring up Chrome’s menu.

  2. Near the bottom of the menu, select Settings.

  3. From the Settings list, select Privacy and security.

  4. Underneath Privacy and Security options, select Site settings.

  5. At the bottom of the Permissions section, in the middle of the page, select Additional Permissions > Local network access.

  6. Next to Allowed to connect to any device on your local network, select Add.

  7. In the text box that appears, enter [*.]duosecurity.com 

 

Cause

Google Chrome version 142 and Microsoft Edge 143 include a change which causes users to see a permission prompt whenever a website attempts to send an HTTP(S) request to a device on the local network or to the loopback connection on the local machine.

This local loopback connection is the mechanism that the Duo Prompt uses to send requests to Duo Desktop

 

More details: https://help.duo.com/s/article/9470?language=en_US

Solution Properties

Keywords
Edge Chrome Duo
Solution ID
251031144941980
Last Modified Date
10/31/2025 04:05:32 PM
Taxonomy
  • Access and Identity Management > DUO Two-factor Authentication
Collections
  • VCU (Public)
  • IT Professionals
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