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Unable to connect to SAS Enterprise Guide

Updated 

Summary

Unable to connect to SAS Enterprise Guide, error message: "Can't connect to metadata server"

Symptoms

When connecting to SAS Enterprise Guide to query data in ODS SAS libraries, the following error message is displayed:

"SAS Enterprise Guide 7.1 not working. Can't connect to metadata server, error message below when connecting profiles:

"A connection could not be established to a metadata server running on port 8561 on host sasbimeta2.vcu.edu."

 

 

Environment

SAS Enterprise Guide

Solution

With the August 2024 migration of the SAS servers, the host server name has been updated for SAS Enterprise Guide.

To update the server name:

  1. Click on Tools -> Connections (keyboard shortcut F9) in SAS Enterprise Guide.
  2. In the Connection wizard pop-up window, under Profiles, click Modify with your active profile selected.
  3. Under Machine, change the server name from sasbimeta2.vcu.edu to sasbimeta.vcu.edu.
  4. Click Save and Connect.

 NOTE: Connection to VPN/ZScaler is required to use SAS Enterprise Guide to connect to ODS libraries.

Please reach out to your desktop support for ZScaler support. 

 NOTE:  Zscaler Installation, How-to, Troubleshooting, and FAQ

Cause

The SAS server name for connecting to SAS Enterprise Guide has changed from sasbimeta2.vcu.edu to sasbimeta.vcu.edu.